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Preface

EuroForth is an annual conference on the Forth programming language, stack
machines, and related topics, and has been held since 1985. The 27th Euro-
Forth finds us in Vienna for the third time. The three previous EuroForths
were held in Vienna, Austria (2008), in Exeter, England (2009), and in Ham-
burg, Germany (2010). Information on earlier conferences can be found at
the EuroForth home page (http://www.euroforth.org/).

Since 1994, EuroForth has a refereed and a non-refereed track. This year
there were no submissions to the refereed track. Nevertheless, I thank the
program committee for its willingness to serve.

Several papers were submitted to the non-refereed track in time to be
included in the printed proceedings. In addition, the printed proceedings
include slides for talks that will be presented at the conference without being
accompanied by a paper and that were submitted in time.

These online proceedings also contain late presentations that were too
late to be included in the printed proceedings.

Workshops and social events complement the program.
This year’s EuroForth is organized by Ewa Vesely and Anton Ertl.

Anton Ertl

Program committee

M. Anton Ertl, TU Wien (chair)
David Gregg, Trinity College Dublin
Phil Koopman, Carnegie Mellon University
Jaanus Pöial, Estonian Information Technology College, Tallinn
Bradford Rodriguez, T-Recursive Technology
Bill Stoddart, University of Teesside
Reuben Thomas, Adsensus Ltd.
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Abstract

This paper describes the instantiation of an ARM Cortex-M1 CPU core on an 
Altera Cyclone III FPGA and the development of a simple Forth application to 
run on it.

The CPU core used here is the ARM Cortex-M1 FPGA Development Kit from ARM, 
Ltd. The Altera Quartus II environment is used to design an ARM system, includ-
ing memory and embedded peripherals. SwiftX-ARM is used to develop and 
interactively test a simple Forth application on the newly instantiated Cortex-M1 
core in the FPGA.

Section 1: Overview

1.1  About SwiftX

SwiftX is FORTH, Inc.’s interactive cross compiler for the development of appli-
cations for embedded microprocessors and microcontrollers. SwiftX is based on 
the Forth programming language and is itself written in Forth. 

SwiftX has been ported to the following microprocessor and microcontroller 
families:

x Atmel, Cirrus, Nuvoton, NXP, ST Microelectronics (and other) ARM cores

x Freescale ColdFire

x Freescale 6801 / Renesas 6303

x Freescale 6809

x Freescale 68HC11

x Freescale 68HC12 (S12, S12X, etc.)

x Freescale 68HCS08

x Freescale 68K

x Aeroflex UTMC 69R000

x Intel (NXP, SiLabs, others) 8051

x Atmel AVR

x Renesas H8H (H8/300H, H8S)

x Intel (AMD, other) i386
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x Texas Instruments MSP430

x Patriot PSC1000

x Harris RTX2010

SwiftX cross-compilers run in the SwiftForth programming environment. They 
inherit all the features of SwiftForth and extend its interactive development 
environment to manage multiple program and data spaces as well as to generate 
the code and data that fill them.

1.2  About the ARM Cortex-M1 FPGA Development Kit

The ARM Cortex-M1 FPGA Development Kit, available free of charge from ARM, 
Ltd., is delivered as an SOPC Builder design optimized for the Altera Cyclone III 
FPGA Starter Kit. The ARM system bus has been adapted to the Altera Avalon 
system interface for this implementation. However, there are no architectural 
changes from the standard ARM Cortex-M1 Core. 

The Cortex-M1 processor is intended for deeply embedded applications that 
require a small processor (i.e., low gate count) integrated into an FPGA. The pro-
cessor core implements the ARM architecture v6-M Thumb Instruction Set Archi-
tecture (ISA) with some 32-bit Thumb-2 extensions.

ARM Cortex-M1 FPGA Development Kit is fully compatible with Altera’s SOPC 
Builder and Quartus II tools. This application note demonstrates how to build a 
simple system from the ARM Cortex-M1 FPGA Development Kit and a few of the 
standard Altera peripheral IP blocks, then generate a bitfile of the whole system 
and program it onto a Cyclone III device. 

1.3  Requirements

The following items are required to implement the system described in this 
application note:

x SwiftX-ARM from FORTH, Inc. (www.forth.com)

x Quartus II (subscription or web edition), version 8.0 or later, from Altera. We 
used Quartus II Web Edition 11.0 for this paper. (www.altera.com)

x ARM Cortex-M1 FPGA Development Kit. (www.arm.com)

x Cyclone III Starter FPGA Kit. (www.altera.com)

x A simple USB-to-serial port converter, such as the DEV-09873 from Sparkfun 
Electronics. (www.sparkfun.com)
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Section 2: Working with Quartus II and SOPC Builder

This section describes the development of a Quartus II project using the SOPC 
Builder tool to fabricate the ARM Cortex-M1 core with memory and peripherals. 
The system is synthesized and downloaded to a Cyclone III FPGA Starter Kit for 
testing.

We are using the Windows version of Quartus II and are placing our project files 
in the directory c:\projects. Make any necessary adjustments to path names if 
you are using the Linux version of Quartus II.

2.1  Starting a new Quartus II Project

Launch Quartus II, dismissing any startup wizards or tips. Select File > New Proj-
ect Wizard and fill in the blanks as follows:

x Set the working directory for the project to C:\projects\cm1\fpga.

x Name the new project cm1.

x Set the top-level design entity name to cm1_top.

x Click the “Next” button (say “Yes” to create the new project directory).

x When you get to the “Add Files” step, just skip it for now. We’ll add some files 
after we build the ARM Cortex-M1 system in SOPC builder.

x For the “Family & Device Settings” step, select the device that matches the one on 
your Cyclone III FPGA Starter Kit (e.g., EP3C25F324C6).

x Click “Next” through the remaining wizard screens and “Finish” on the last one.

2.2  Working with SOPC Builder

The Quartus II SOPC Builder tool is used to build and integrate the ARM Cortex-
M1 CPU, clocks, memory, PIO, and UART components. The Cortex-M1 CPU core 
is supplied by ARM, Ltd. The remainder of the IP components are from Altera 
and are distributed with the Quartus II system.

Select Tools > SOPC Builder in Quartus II and follow the directions in the follow-
ing sections to build the ARM Cortex-M1 system.

For “System Name” in the “Create New System” dialog box, enter “cm1” and 
select Verilog as the HDL. Do not use the same name assigned to the top-level 
entity.

2.2.1  Adding the ARM Cortex-M1 core

Look for “ARM Cortex-M1 Processor” in the Component Library pane of the 

SOPC Builder window, select it as shown in Figure 1 and click the “Add” button1.�
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Figure 1.  ARM Cortex-M1 Processor component selection

Configure the ARM Cortex-M1 processor as follows:

x Uncheck the “Debug enabled” box

x Set number of IRQs to 8

x Set ITCM size to 16 kB

x Uncheck “Read only” for the ITCM

x Check “Initialize ITCM contents” 

x Set ITCM “From file” field to itcm.hex (this should be the default)

x Set DTCM size to 8 kB

x Uncheck “Initialize DTCM contents”

x Click the “Finish” button to add the ARM Cortex-M1 core to the SOPC design

2.2.2  Adding parallel I/O (PIO)

The SwiftX demo for the Cortex-M1 will use a 4-bit PIO to drive the four user 
LEDs and read the four user pushbuttons on the Cyclone III FPGA Starter Kit 
board.

From the Component Library, select Peripherals > Microcontroller Peripherals > 
PIO and click the “Add” button. Configure the PIO component as follows:

x Set the width to 4 bits

x Set direction to “InOut”

x Set the output port reset value to 0x0F

x Leave the rest of the PIO option boxes unchecked

x Click the “Finish” button to add the PIO to the SOPC design

2.2.3  Adding a UART

The SwiftX Interactive Development Environment uses a fast serial port as its 

1.If the ARM Cortex-M1 Processor item is not present, use Tools > Options to add the 

path to ARM/CortexM1_DevKit/Component/arm_avalon_cortexm1 to the IP Search 

Path.
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Cross-Target Link (XTL) debug interface.

From the Component Library, select Interface Protocols > Serial > UART (RS-232 

Serial Port)1. Configure the UART component as follows:

x Under “Basic Settings,”, use the defaults (no parity, 8 bits, 1 stop bit, 2 synchro-
nizer stages, no RTS/CTS, no EOP).

x Select a fixed baud rate of 115200 with error tolerance of 0.01

x Leave the remaining options unchecked

x Set the transmitter baud rate to “Actual” (not “Accelerated”)

x Click the “Finish” button to add the UART to the SOPC design

2.2.4  Connecting the components

In SOPC builder, click on the “Filter” button and set the Filter pull-down to “All” 
so you can see all the connections. 

Set the bus, clocks, and interrupt connections as well as the component base 
addresses and IRQ as shown in Figure 2.

Figure 2.  Component connections and settings

The base address for the PIO is 0xA0000000 and the UART is 0xA0000100. Use 
IRQ 0 for the UART “interrupt sender” element.

2.2.5  Generate the SOPC system

Click the “Generate” button to generate the system. When prompted to save the 
file, name it cm1.sopc. 

After the generation is complete, you should see the “System generation was 
successful” message in SOPC Builder’s output pane. Click the “Exit” button to 
close the SOPC Builder window, saving any changes to the cm1.sopc file.

1.Do not use the JTAG UART component.
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2.3  Adding the Top-Level Design

We need to add a top-level design file to make some connections to the ARM 
Cortex-M1 core and peripherals generated by SOPC Builder. We’ll do this with a 
simple block diagram/schematic file.

Select File > New and choose “Block Diagram/Schematic File” in the New dialog 
box, then click “Ok.” A blank block1.bdf workspace should appear in the right 
window pane. Follow these steps to create and save the top-level design file:

x Double-click in the center of the schematic grid workspace. This should open the 
Symbol dialog.

x In the “Libraries” pane, expand the “Project” item and select cm1. This should 
show the cm1 block entity in the right pane.

x Click “Ok”.

x Position the block roughly in the center of the schematic and click to position it.

Now we need to tie a few of the unused inputs to Vcc and Gnd levels:

x Double-click on the schematic to open the Symbol dialog.

x Expand the Quartus Libraries item and select Primitives > Other > Vcc.

x Click on the schematic to place Vcc next to the cm1 node’s DBGRESETn input.

x Select a Node tool and connect Vcc to DBGRESETn.

x Double-click on the schematic to open the Symbol dialog.

x Expand the Quartus Libraries item and select Primitives > Other > Gnd.

x Click on the schematic to place Gnd next to the cm1 node’s EDBGRQ input.

x Select a Node tool and connect Gnd to both EDBGRQ and NMI inputs.

x Use the Selection tool and select the entire cm1 object.

x Right-click on cm1 and select “Generate Pins for Symbol Ports.”

x Save the schematic file as cm1_top.bdf.

x In the Project Navigator pane, select the Files tab, right-click on cm1_top.bdf and 
select “Set as Top-Level Entity.”

Figure 3 shows a representation of the top-level design schematic.

Figure 3.  Top-Level design schematic
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2.4  Synthesizing the System

The files generated by SOPC Builder along with our top-level design need to be 
analyzed so we can assign pin connections to the outside world.

Select Processing > Start > Start Analysis and Elaboration so Quartus II can ana-
lyze the design and figure out its pins and connections. The process should 
complete with the message “Analysis & Elaboration was successful.”

2.4.1  Assigning nodes and pins

x Select Assignments > Assignment Editor to make the pin assignments.

x In the Assignment Editor window, click on a cell in the “To” column and select 
Node Finder. Select “Pins: all” (“Look in:” should be cm1_top) and click “List” to 
see all the internal pins.

x Select the pins listed in the “Signal” column of Figure 4 and add them to the pane 
on the right.

x In the assigment editor, set the Assignment Name field for all pins to “Location” 
and enter the physical pins listed in Figure 4 into the Value column and set the 
Enabled column to “Yes” for each pin.

x Close the Assignment Editor, saving the new assignments when prompted.

Figure 4.  Pin assignments

2.4.2  Compiling the system

Copy the itcm.hex object file from the projects\cm1\firmware project directory to 
the projects\cm1\fpga directory. If there is no itcm.hex file in the SwiftX project 
directory, launch the SwiftX project in that directory and do a “Build” to compile 
the ARM Cortex-M1 SwiftX kernel.

Then go back to the Quartus II window and select Processing > Start Compila-
tion. The compilation step takes a few minutes to complete. When it is done, 

NET NAME SIGNAL PIN

50MHZ clk_0 V9

CPU_RST_N reset_n N2

HSMC_SCL rxd_to_the_uart_0 F3

HSMC_SDA txd_from_the_uart_0 E1

KEY0 in_port_to_the_pio_0[0] F1

KEY1 in_port_to_the_pio_0[1] F2

KEY2 in_port_to_the_pio_0[2] A10

KEY3 in_port_to_the_pio_0[3] B10

LED0 out_port_from_the_pio_0[0] P13

LED1 out_port_from_the_pio_0[1] P12

LED2 out_port_from_the_pio_0[2] N12

LED3 out_port_from_the_pio_0[3] N9
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there will be some warnings in the output window, but there should be no error 
messages.

2.4.3  Programming the FPGA

Connect a USB port on the computer running Quartus II to the USB Blaster 
embedded on the Cyclone III FPGA Starter Kit board. Select Tools > Programmer 
and under Hardware Setup, select the USB Blaster, setting its mode to JTAG. 

Select the cm1.sof file1 and click the “Start” button. Figure 5 shows the program-
mer dialog box after loading the FPGA.

Figure 5.  Programmer dialog box

The target board should start running the ARM Cortex-M1 SwiftX program from 
itcm.hex.

1.The exact name of the SOF file may vary.
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Section 3: Working with SwiftX

3.1  Connecting the debug interface

A serial port is used for the debug interface from the SwiftX Interactive Develop-
ment Environment to the target ARM Cortex-M1 CPU inside the Cyclone III FPGA. 
The four pins on the Cyclone III FPGA Start Kit board originally intended for I2C 
connections have been reassigned in our design to be used as the UART pins. 
The pin assignments are as follows:

Connect a USB cable from the computer running SwiftX to a USB-to-serial con-

verter1 connected to the target board as noted above.

3.2  Establishing an interactive session

Click on the “Debug” button in the SwiftX tool bar (or select Tools > Debug or 
press the F9 shortcut key) to establish a serial connection with the target CPU 
and launch an interactive debug session. The output in the SwiftX debug window 

should look something like this:2

I N C L UDE  D E BU G

   S t a r t       E n d       S i z e      U s e d    U n u s e d     T y p e    N a me
    0 0 0 0      3 F F F      1 6 3 8 4      7 6 4 0      8 7 4 4     C D A T A   P ROG
2 0 0 0 0 0 0 0  2 0 0 0 1 0 F F       4 3 5 2        1 2      4 3 4 0     I DA T A   I R AM
2 0 0 0 0 1 0 0  2 0 0 0 1 F F F       7 9 3 6      2 3 1 6      5 6 2 0     U DA T A   URAM

T A RGE T  R E A DY
Sw i f t X / A RM C o r t e x - M 1  A l t e r a   o k

Interactive development and testing can now proceed as described in the SwiftX 
Reference Manual and the SwiftX ARM Target Reference Manual.

3.3  Project source files

The project directory projects\cm1\firmware contains the usual set of files as 
documented in the the SwiftX Reference Manual. In addition to these, the follow-
ing project-specific files are supplied:

1.TTL levels required.

SDA TXD

SCL RXD

3V3 N/C

GND GND

2.Exact memory usage may vary.
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x reg_fpga.f — Defines the memory-mapped register interface to the Altera PIO and 
UART components.

x xtl_uart0.f — Implements the target side of the serial cross-target link (XTL) 
debug interface using the Altera UART added to the design in 2.2.3.

x leds.f — Uses the Altera PIO core component to interface to the four user LEDs 
on the Cyclone III Starter FPGA Kit board. 

x buttons.f — Uses the Altera PIO core component to interface to the four user 
pushbuttons on the Cyclone III Starter FPGA Kit board. 

x demo.f — Implements a high-level W I NK  function and assigns a “walking” LED 
wink pattern to a SwiftX B A CK GROUND task.

The output file generated by the SwiftX BU I L D process is itcm.hex. It must be cop-
ied or moved into the projects\cm1\fpga directory prior to compiling the FPGA 
project in Quartus, as described in 2.4.2.

3.4  Demo Application

The demo application consists of a background task that drives the LEDs in a 
“chase” pattern. The user pushbuttons are tested in the main application loop to 
change the speed of the chasing pattern (by setting the LED on/off time to a lon-
ger or shorter period) and to perform an “all on” LED test.

Excerpts from the Forth source files are included in the next section.

Conclusion

The instantiation of the ARM Cortex-M1 processor on an Altera FPGA using 
SOPC Builder is a simple task that can be accomplished even by someone with 
limited FPGA programming experience. 

Additional memory and peripherals can be added in SOPC Builder for a much 
more elaborate implemenetation. Custom logic can be included in the design 
from the top level using conventional FPGA tools.

Porting a Forth cross compiler and interactive debug environment to this CPU is 
no more daunting than a port to a conventional CPU.
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Section 4: Program Listings

4.1  LED Outputs

{  - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
L E D  c o n t r o l

! L E D  w r i t e s  a  p a t t e r n  t o  t h e  4  L E D S  i n  b i t s  [ 3 : 0 ]  o f  t h e  P I O  o u t p u t
r e g i s t e r .
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -  }

:  ! L E D S  (  x  - -  )    I N V E R T  P I O _ B A S E  !  ;
:  / L E D S  (  - -  )    0  ! L E D S  ;

4.2  Button inputs

{  - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
R e a d  s w i t c h e s

? P R E S S E D  r e t u r n s  t r u e  i f  b u t t o n  d e f i n e d  b y  m a s k  i s  p r e s s e d .
B U T T O N 1 . . B U T T O N 4  d e f i n e  m a s k s  f o r  p a s s i n g  t o  ? P R E S S E D .
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -  }

:  ? P R E S S E D  (  m a s k  - -  f l a g  )    P I O _ B A S E  @  A ND 0 =  ;

1  C O N S T A N T  B U T T O N 1
2  C O N S T A N T  B U T T O N 2
4  C O N S T A N T  B U T T O N 3
8  C O N S T A N T  B U T T O N 4

4.3  Demo program

{  - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
L E D  d e m o  p r o g r a m

L E D T I M E  h o l d s  t h e  n u m b e r  o f  m i l l i s e c o n d s  f o r  L E D  o n  a n d  o f f  p e r i o d .

F A S T ,  M E D I U M ,  a n d  S LOW a r e  t h e  n u m b e r  o f  m i l l i s e c o n d s  f o r  t h r e e  s p e e d s .
S P E E D  s e t s  L E D T I M E  t o  u  mi l l i s e c o n d s .

CHE C K - B U T T O N S  d o e s  t h e  f o l l o w i n g  b a s e d  o n  b u t t o n ( s )  p r e s s e d :
  B u t t o n  1 :  S e t  s l o w  s p e e d
  B u t t o n  2 :  S e t  m e d i u m  s p e e d
  B u t t o n  3 :  S e t  f a s t  s p e e d
  B u t t o n  4 :  T u r n  a l l  L E D s  o n

L E D - C H A S E  p e r f o r m s  o n e  l o o p  o f  t h e  L E D  " c h a s e "  s e q u e n c e .
CHE C K - B U T T O N S  i s  c a l l e d  j u s t  b e f o r e  t h e  o n  o r  o f f  d e l a y  t i m e .

CHA S E R  i s  t h e  t a s k  a s s i g e d  t o  p e r f o r m  t h e  c h a s i n g  L E D s  b e h a v i o u r .
/ C H A S E R  s t a r t s  t h e  t a s k .
D E M O  i n i t i a l i z e s  t h e  L E D S  a n d  t i m e  p e r i o d ,  t h e n  s t a r t s  t h e  t a s k .
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -  }

V A R I A B L E  L E D T I M E         \  M i l l i s c o n d s  o n / o f f  t i m e

5 0  C O N S T A N T  F A S T
1 0 0  C ONST A N T  MEDI U M
2 5 0  C ONST A N T  S L O W

:  S P E E D  (  u  - -  )    L E D T I M E  !  ;
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:  C H E C K - B U T T O N S  (  - -  )
   B U T T O N 1  ? P R E S S E D  I F   S L OW S P E E D   T H E N
   B U T T O N 2  ? P R E S S E D  I F   M E DI U M  S P E E D   T HEN
   B U T T O N 3  ? P R E S S E D  I F   F A S T  S P E E D   T H E N
   B U T T O N 4  ? P R E S S E D  I F   $ 0 F  ! L E D S   T HEN  ;

:  L E D - C H A S E  (  - -  )    1
   4  0  D O  DUP  ! L E D S   CHE C K - B U T T O N S   L E D T I ME @  M S   2 *   L OOP
   4  0  D O  2 /  D U P  ! L E D S   CHE C K - B U T T O N S   L E D T I M E  @  M S   L O O P  DRO P  ;

| U |  | S |  | R |  B A C K GROUND C H A S E R

:  / C H A S E R  (  - -  )    CHA S E R  A C T I V A T E
   B E G I N   L E D- C H A S E   A G A I N  ;

:  DEMO  (  - -  )
   0  ! L E D S   ME D I U M  S P E E D   CH A S E R  B U I L D   / C H A S E R  ;
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SWIG & The Forth Net: Hands-OnGerald Wodni∗ M. Anton Ertl †Euroforth 2011Abstra
tWe have shown the basi
 fun
tionality of SWIG and The Forth Net in the past. Now we wantto provide two basi
 examples whi
h explain how to use them and to show how easy it is to 
reateC-interfa
es or Forth-libraries and share them.1 MySQL in ForthAs all mayor Forth-systems provide an interfa
e to 
all libraries written in the C-programming-language,it should be quite easy to load and use a library like MySQL. But as all of them have their very owninterfa
e with their own set of words, this task 
an be quite 
umbersome. The Forth extension for SWIG[1℄ attempts to provide an easier way, by 
reating a C-sour
e-�le whi
h is platform independent and on
eit gets 
ompiled, outputs the interfa
e information for the target Forth-system.First we need to 
reate an interfa
e �le for SWIG[2℄:1 %module mysql2 %i n s e r t (" f s i i n 
 l u d e ")3 %{4 #in
 lude <mysql/mysql . h>5 %}67 %in
 lude <mysql . h>Line 1 tells SWIG the name of our module.Lines 2-5 put Line 4 into the output-�le in the se
tion �fsiin
lude�, whi
h happens to be right after thedefault #in
lude-dire
tives.Line 7 orders SWIG to parse mysql.h .Having 
ompleted the interfa
e �le we invoke SWIG:$ swig −f o r t h −sta
k
omments − i n 
 l u d e a l l −I / usr / in
 lude /mysql −o mysql− f s i . 
 mysql . iDepending on our system we may add some more in
lude dire
tories (-I...). The resulting �le (mysql-fsi.
) is platform independent and is exa
tly what we 
an upload to The Forth Net (see Se
tion 2), orshare in general.On the target ma
hine we 
ompile the mysql-fsi.
 �le using the ma
hine's C-
ompiler, whi
h in
ludesthe C-headers and thereby assigns the 
orre
t values for 
onstants, the 
orre
t typedefs and 
ares aboutall other C-related problems.We get a binary whi
h we assume to be named mysql.fsx . Exe
uting it will print the sele
tedsystem's C-interfa
e de�nition. Redire
ting it into mysql.fs gives us the desired Forth-sour
e-�le whi
hwe 
an simply in
lude.$ mysql . f s x −g f o r th > mysql . f s
∗TU Wien; gerald.wodni�gee.at
†TU Wien; anton�mips.
omplang.tuwien.a
.at 1
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We now have enabled Forth to a

ess MySQL. See Appendix A for a simple example of the library ina
tion. All of the above steps after 
reating the interfa
e �le 
an be done at on
e by using the Make�leof Appendix A. If we want to share our newly 
reated library, Se
tion 2 gives an example of how to dojust that.2 Library for The Forth NetLet us 
onsider we wrote a library for 3D-graphi
s and want to share it. However, in order to make thislibrary truly system independent and easily a

essible, we have to introdu
e some new words explainedbelow. All words start with �f� whi
h relates to The Forth Net[3℄.frequire ( . . . "�le" � . . . ) Some Forth-systems use the working dire
tory as the base dire
tory for in-
luding �les by relatives paths. Others use the �le whi
h is 
urrently parsed as the base dire
tory.To 
ir
umvent ambiguities for our library we 
ould use absolute paths. Unfortunately this de
isionwould for
e an absolute path on all users, whi
h is not an option. frequire prepends the librariesbase path on the 
urrent system to "�le" and loads it.�n
lude ( . . . "name" � . . . ) Loads the library by in
luding its main �le.fget ( . . . "name" � . . . ) Downloads the library from The Forth Net[4℄ to the libraries-root-path.Using these words we 
an now extend respe
tively write our library. Our dire
tory stru
ture is asfollows:3d 3d.fsmodelsmodel.fssphere.fs
ube.fsdatatree.tgawater.tgado
README.txtVERSIONINFO�3d.fs� is the libraries main �le whi
h is in
luded by the user who uses �fin
lude 3d�. The library allowsthe user to draw 
ubes and spheres, so �3d.fs� will provide them by using �frequire models/
ube.fs� and�frequire models/sphere.fs�. Cubes and spheres use words whi
h are 
ommon amongst all models, andare de�ned in models/model.fs, so both �les use �frequire models/models.fs� (we always address �lesfrom the libraries base-path).All other �les are optional: the dire
tory �data� provides the library with some textures, �do
� holds thedo
umentation, whi
h explain the user how to use the 3d-library. The 
ontent of the �le �VERSIONINFO�is displayed on The Forth Net when browsing di�erent versions, and hold some information about re
entimprovements or bug �xes.The �nal step of sharing our library is to upload it to The Forth Net. This is a

omplished by 
reatinga new proje
t, 
li
king manage, zipping the 
ontents of the dire
tory 3d (not in
luding the dire
toryitself), and submitting them as a new version.From this moment on others 
an fet
h the library by using �fget 3d�
2
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A MySQL Demo[5℄1 \ ( 
 ) 2011 by Gerald Wodni2 \ very smal l example f o r i n t e r f a 
 e i n g with the 
−api of mysql34 \ load binary shared l i b r a r y5 s " mysq l 
 l i e n t" add− l i b67 \ in
 lude f un
 t i on s and 
ons tant s8 f i n 
 l u d e f s i −mysql−
 l i e n t910 \ d i sp l ay 0−terminated s t r i n g11 : . 
 s t r ( addr −− )12 beg in13 dup 
�14 whi le15 dup 
� emit16 
har+17 r epeat drop ;1819 \ −− r e a l program −−20 \ 
 r e a t e 
onne
t ion element21 0 mysql_init 
onstant 
onne
t ion2223 \ 
onne
t24 
onne
t ion s \" l o 
 a l h o s t \0" drop s \" f o r th \0" drop s \" h4x0r \0"25 drop s \" f o r th \0" drop 0 0 0 mysql_real_
onne
t [ i f ℄26 . " 
onne
t ion  e s t a b l i s h e d " 
r27 [ e l s e ℄28 . " 
onne
t ion  e r r o r " 
r bye29 [ then ℄3031 \ laun
h query32 
onne
t ion s \" SELECT ∗ FROM ` systems `  \0" drop mysql_query [ i f ℄33 . " Query−Error :  " 
onne
t ion mysql_error . 
 s t r 
r bye34 [ then ℄3536 \ p r i n t r e s u l t37 : tab 9 emit ;38 : show−r e s u l t ( −− )39 \ get r e s u l t40 
onne
t ion mysql_use_result41 beg in42 dup mysql_fet
h_row ?dup43 whi le44 
onne
t ion mysql_fie ld_
ount 0 u+do45 dup � tab . 
 s t r46 
 e l l+47 l oop drop48 
r49 r epeat50 mysql_free_resu l t ;5152 . " Resu l t : " 
r53 show−r e s u l t5455 
onne
t ion mysql_
lose56 . " 
onne
t ion  
 l o s ed " 
r5758 bye
3
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A FSI-Make�le[5℄1 SWIG = swig2 OUTPUT = mysql3 INTERFACE = mysql . i4 OPTIONS = −f o r t h −no−se
t ion
omments −sta
k
omments − i n 
 l u d e a l l \5 −I / usr / in
 lude /mysql −I / usr / in
 lude \6 −I / usr / l i b / g

 / i486−l inux−gnu /4 .1/ in
 lude /78 $ (OUTPUT) . f s : $ (OUTPUT) . f s x9 . / $ (OUTPUT) . f s x −g f o r th > $ (OUTPUT) . f s1011 $ (OUTPUT) . f s x : $ (OUTPUT) . f s i12 $ (CC) −o $ (OUTPUT) . f s x $ (OUTPUT)− f s i . 
1314 $ (OUTPUT) . f s i :15 $ (SWIG) $ (OPTIONS) −o $ (OUTPUT)− f s i . 
 $ (INTERFACE)1617 .PHONY: 
 l ean1819 
 l ean :20 rm − f $ (OUTPUT)− f s i . 
21 rm − f $ (OUTPUT) . f s22 rm − f $ (OUTPUT) . f s xReferen
es[1℄ Gerald Wodni and M. Anton Ertl. SWIG-Gforth-Extension. In Euroforth, 2009.[2℄ David M. Beazley et al. Simpli�ed Wrapper and Interfa
e Generator (SWIG). URL http://www.swig.org.[3℄ Gerald Wodni and M. Anton Ertl. The Forth Net, 2010.[4℄ Gerald Wodni. The Forth Net. URL http://theforth.net.[5℄ Gerald Wodni and M. Anton Ertl. SWIG Erweiterung für Forth Neuigkeiten, 2011.
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Ways to Reduce the Stack Depth

M. Anton Ertl∗

TU Wien

Abstract

Having to deal with many different data can lead to
problems in Forth: The data stack is the preferred
place to store data; on the other hand, dealing with
too many data stack items is cumbersome and usu-
ally bad style. This paper presents and discusses
ways to unburden the data stack; some of them are
used widely, others are almost unknown or new.

1 Introduction

The data stack is the primary mechanism for pass-
ing data around in Forth. Its advantages include:
words that deal only with the stacks are reentrant,
i.e., they can be used recursively and in several tasks
running at the same time; and straight-line code us-
ing the stack can be factored easily (just split any
subsequence off into a separate colon definition).

The limitations of the data stack are: It can con-
tain only cell-sized items. And while it may con-
tain many items, accessing more than a few alter-
natingly requires quite a bit of stack shuffling and
is hard to read; idiomatic in Forth usage tries to
avoid stack shuffling.

However, some problems inherently have to deal
with more than the about three data items that can
be managed without too much shuffling.

A commonly-used example problem is drawing a
rectangle specified, e.g., by the lower left and up-
per right point, using line-drawing primitives that
take the start point and the end point: If each point
is specified by two numbers, the rectangle is repre-
sented by four numbers. Moreover, each number is
needed after the first line is drawn, so just before
the first line primitive we would have the four num-
bers for the rectangle on the stack, plus the four
numbers needed for the line primitive. Many differ-
ent ways have been suggested for dealing with this
example problem and others.

This paper looks at various ways to deal with
such problems, and discusses the advantages and
disadvantages.

∗Correspondence Address: Institut für Computer-

sprachen, Technische Universität Wien, Argentinierstraße 8,

A-1040 Wien, Austria; anton@mips.complang.tuwien.ac.at

2 Grouping data in memory

One approach is to store much of the data in one
or few structures in memory, and putting only the
address of the structure(s) on the stack. The disad-
vantage here is that it requires managing the mem-
ory for the structures; this includes specifying who
is responsible for deallocating the memory.

In our rectangle example, we might represent
each point as a structure, both in the input of our
rectangle word and in the calls to the line-drawing
words, but this would mean that we would have to
allocate, fill, and later deallocate at least two such
point structures (for the lower right and upper left
point of the rectangle), and let the caller deallocate
the structures (somewhat contrary to the Forth id-
iom of consuming stack items):

: line-line ( p1 p2 p3 -- )

\ draw a line between p1 and p2

\ and one between p2 and p3

over line line ;

: rect ( ll ur -- )

over point-x @ over point-y @ make-point

( ll ur ul )

>r 2dup r@ swap line-line r> free-point

over point-y @ over point-x @ swap make-point

( ll ur lr )

>r 2dup r@ swap line-line r> free-point ;

Of course, we could pass in the data to rect in
a structure and pass it to line on the stack, so the
memory management would not show up in rect,
but that would be less instructive, failing to show
that memory management overhead occurs.

Given that Forth does not normally have auto-
matic memory management (aka garbage collec-
tion), I tend to avoid such solutions where possible.

3 Multiple Stacks

A common way to deal with many stack items is to
put some of them on the return stack. The return
stack allows no shuffling and only direct access to
the top item, and data has to be moved or copied
back to the data stack for computations, so this
is usually limited to just one or two items. The
disadvantage of this strategy is that we lose the nice
factoring property of data-stack-only code: there
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are some straight-line code sequences in code using
the return stack that cannot simply be split of into
a separate colon definition.

Floating-point code keeps floating-point numbers
on the separate FP stack, so the number of items
on the data stack (and the number of items on the
FP stack) is usually smaller than in equivalent in-
teger code, and there is usually much less shuffling
necessary.

As an example, consider the following word from
the integer matrix multiplication benchmark:

: innerproduct ( a b -- n )

\ a points to a column in a matrix

\ b points to a row in a matrix

0 row-size 0 do

>r over @ over @ * r> + >r

swap cell+ swap row-byte-size +

r>

loop

>r 2drop r> ;

Note that this code already reduces the stack load
by passing row-size and row-byte-size in con-
stants. A floating-point variant of the word looks
like:

: finnerproduct ( a b -- r )

0e row-size 0 do

over f@ over f@ f* f+

swap float+ swap row-byte-size +

loop

2drop ;

All the return stack usage went away.

The main disadvantage of the FP stack is the
additional implementation cost: managing another
memory area for this stack, per task; and having
another stack pointer that has to be saved and re-
stored by context switches and in exception han-
dling.

Some people have suggested additional stacks,
e.g., an address stack or a string stack. This has
not really caught on yet. In addition to the costs
mentioned above one often wants to use operations
like - on addresses and, e.g., string lengths. Keep-
ing these types on separate stacks would require
moving these data between the stacks for such op-
erations, which will increase the stack noise in some
cases.

4 Locals

Locals offer a way to deal with lots of data. E.g., for
our rectangle example a solution using locals would
be:

: rect {: x1 y1 x2 y2 -- :}

x1 y1 x1 y2 line

x1 y2 x2 y2 line

x2 y2 x2 y1 line

x2 y1 x1 y1 line ;

The result is readable and this approach scales to
dealing with many data.

Despite these advantages, using locals has been
vilified often by a considerable portion of the Forth
community. One disadvantage of this approach is
that we lose the nice factoring properties of data-
stack-only code, but using the return stack has the
same disadvantage without having the same accep-
tance problems as locals.

A common argument against using locals is that
locals discourage proper factoring; they only dis-
courage it in the same way that the return stack
does, but maybe the complaint really is that due to
the scalability they fail the encourage factoring in
the same way that stack-based approaches do; i.e.,
that locals take away the pressure to factor for less
active data at a time, because words that deal with
lots of data still remain manageable.

The question then is why we want a more highly
factored program. If locals achieve that goal (say,
readability) with less factoring, do we need more
factoring? If not, maybe we should be aware of
and strive for the desired property instead of just
avoiding some programming language features.

5 Global/user variables

5.1 ... within single definitions

Another related approach is using global variables.
As long as you use them inside a single colon def-
inition, the readability and scalability is similar to
using locals. And in contrast to locals, in some
respects they keep the nice factoring properties of
data-stack-only code. The disadvantages are that
the result is not reentrant or usable recursively un-
less special measures are taken.

The most serious problem, though, is: if you
make use of the factoring properties, now the data
does not just flow through the stack from caller to
callee and back, but through an arbitrary set of
global variables. This makes the data flow hard to
track, and makes programs hard to maintain. If you
want to avoid that, you lose the factoring property
with globals just as you lose it with locals.

Also, one nice property of normal factors is that
they are often useful for other purposes; however,
factors involving globals do not have a nice stack-
based calling interface, but something more compli-
cated, so they are usually not nice factors.

In conclusion, while globals are in theory less of
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an obstacle to factoring than locals, it’s usually bet-
ter to avoid this kind of factoring.

If we use user variables to make the word reen-
trant in the presence of multiple tasks or threads,
the variables consume space in each task, all the
time. With cooperative multi-tasking, we can avoid
that as long as the variables live only between task
switches (which creates another maintenance prob-
lem), but with true concurrency this trick no longer
works; and we want to use true concurrency on the
increasingly pervasive multi-core CPUs.

5.2 ... across definitions

Global/user variables are sometimes used as addi-
tional input or output parameters for words. An
example in standard words is #, which takes base

as additional input and produces additional output
in the pictured numeric output buffer.

This global state complicates the interface, which
reduces reusability and causes maintenance prob-
lems. An example is trying to debug code between
<# and #> using .s.

One programming practice for reducing these
kinds of problems is to save the global variable be-
fore changing it and restoring it before returning to
the caller. An example of this practice is:

: hex.-helper ( u -- )

hex u. ;

: hex. ( u -- )

base @ >r

[’] hex.-helper catch

r> base ! throw ;

However, this practice is somewhat cumbersome
to program and Charles Moore prefers to just set
global state whenever that is needed [Bro04, Page
212]; this is a bad idea for reusability, but Moore
does not value reusability of code.

6 Context wrappers

Saving, changing, and restoring a global variable
can be factored out into a context wrapper. E.g.,
Gforth has a word base-execute that saves base,
changes it, executes an xt, then restores base. A
usage example is:

: hex. ( u -- )

[’] u. $10 base-execute ;

\ base-execute ( xt u -- )

Another example is execute-parsing, which
saves the input stream, sets it to the passed-
in string, executes an xt, and restores the input
stream. A usage example is $create, which takes

the name of the created word from a string instead
of the input stream:

: $create ( c-addr u -- )

[’] create execute-parsing ;

\ execute-parsing ( c-addr u xt -- )

A third example of this pattern is
>string-execute which redirects the console
output (e.g., type) into a string. This allows the
programmer to construct strings from many or
complicated words without having to deal with
intermediate strings on the stack.

: fe.>string ( r -- c-addr u )

[’] fe. >string-execute ;

\ >string-execute ( xt -- c-addr u )

The general convention used in Gforth (with the
exception of base-execute, which came before the
convention) is to pass the execution token into the
context wrapper on the top of stack, because it is
usually a literal.

An advantage of context wrappers is that they
make it possible to use words that would otherwise
be specific to some global resource (e.g., the console
output in case of fe.) in a more general way; with-
out a word like >string-execute, if you want to
transform an FP number into engineering notation,
you have to reimplement most of fe. yourself.

So context wrappers do not only make it possible
to reduce stack shuffling in new code, but also to
reuse some code in ways for which it has not origi-
nally been written.

Gforth also has the words infile-execute and
outfile-execute that allow to use console input
(key) or output (type) words for input from or out-
put to a file. A special advantage of using a context
wrapper here is that it restores the old, working
setting if an error is thrown; in contrast, if an error
occurs during a global redirection of console I/O,
the user has problems recovering from the error (es-
pecially if input is redirected).

The usual implementation of context uses
global/user variables and saves the contents of these
variables on the return stack when performing a
context wrapper. The disadvantage of this ap-
proach is that each context requires space for an-
other user variable in each task.

Hanson and Proebsting [HP01] discuss a related
concept: dynamically scoped variables; they also
present several implementation techniques that may
require less memory (but more run-time) than ap-
proach of using global/user variables with saving.
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7 Implicit Parameters and Re-
sults

A common pattern in reducing the number of items
on the data stack is implicit parameters and re-
turn values. The context in context wrappers and
global/user state like base are two examples of this
pattern.

Another one is the loop control parameters in do

loops. The equivalent begin loops would often have
too many items on the stack to manage easily.

Finally, a number of object-oriented Forth exten-
sions have an implicit current object, e.g., this in
objects.fs [Ert97]; in this objects extension, the
current object is set automatically from the top-of-
stack when entering a method and the old current
object is restored when leaving the method. By con-
trast, in Bernd Paysan’s oof.fs model, the current
object is set explicitly, but is then used implicitly
whenever calling a method. In both objects exten-
sions, the current object is used implicitly when ac-
cessing fields of the current object.

8 Registers

ColorForth has the programmer-visible register A,
which is used for memory accesses (e.g., Forth’s !

becomes ColorForth’s A! !); moreover, the top of
the return stack R serves a similar function. Virtual
machine models with even more registers have been
proposed [Pel08].

A value in A does not have to be kept on the
stack, reducing stack load. This is supported by @+

!+, a fetch and store that autoincrement the address
in A.

These registers are global resources and share
many of the disadvantages of globals. However,
their usage model is somewhat different from or-
dinary globals:

• Most globals are specific for one particular pur-
pose, whereas any word that accesses memory
will set A in ColorForth. So, the usage of regis-
ters is much more temporary, and programmers
typically don’t expect the contents to survive
across calls (unlike, usually, globals). So, they
don’t reduce the stack load across calls.

• Interrupt handlers and task switchers will pre-
serve the contents of the registers across the
interrupt or for the next execution of the task,
so the registers can be used in reentrant code.

9 Example: Postscript Graph-
ics Model

The Postscript graphics model demonstrates some
of the ideas presented up to now in action. Here is
the rectangle example, written in Forth, but with
Postscript graphics operators as words:

: rectangle ( x y w h -- )

2swap moveto

over 0 rlineto

0 swap rlineto

negate 0 rlineto

closepath stroke ;

First, we have adapted the parameters of
rectangle (width and height instead of the coordi-
nates of the other corner), because that requires less
stack shuffling in combination with the Postscript
graphics operators. Now, to the essential parts:

Postscript has the current point as implicit pa-
rameter. We start out by setting the current point
with moveto.

Then we draw the first line with rlineto; the
current point determines the start of the line, and
the basis for our relative operation1, so we change
x by w and y by 0; rlineto also sets the current
point to the end point of the line.

The next rlineto draws the second, vertical line
of our rectangle, the third rlineto draws the third
line.

Actually, these words did not draw lines, they cre-
ated a path in the (implicit) graphics state (which
contains the current point and other information).
Now we add a final line to the path with closepath

that goes back to the start of the path.
Finally, stroke draws the lines described by the

path onto the canvas (the in-memory representa-
tion of the page). It takes a number of addi-
tional implicit parameters into account: line width,
colour, dash patterns, corner shape, scale and rota-
tion (more generally, a transformation matrix).

As we can see, Postscript makes effective use
of implicit parameters through the global graph-
ics state. To avoid some of the problems of global
state, Postscript provides gsave to save the current
graphics state on a dedicated graphics state stack,
and grestore to change it back to the old value.

10 Staged Execution

Another way to reduce the number of items on the
stack at any one time is to divide the computation
into different stages. The first stage deals with some

1In addition to the relative rlineto, which takes a coordi-

nate relative to the current point, Postscript also has lineto,

which draws a line to an absolute coordinate.



40

Ertl Ways to Reduce the Stack Depth

of the data and generates code for the second stage,
the second stage deals with more data, and either
completes the computation or generates code for a
further stage, etc.

As an example, consider innerproduct from the
matrix multiply benchmark. The single-stage ver-
sion (already shown in Section 3) looks like this:

: innerproduct ( a b -- n )

0 row-size 0 do

>r over @ over @ * r> + >r

swap cell+ swap row-byte-size +

r>

loop

>r 2drop r> ;

a b innerproduct .

This version already uses a number of techniques
to reduce the stack depth: a do loop to get rid of
the stack items for loop control; the number of el-
ements in the vectors (row-size), and the strides
(cell and row-byte-size) are not passed in through
the stack; and the return stack is used for the in-
termediate result.

Here is a version that divides the execution into
two stages:

: gen-innerproduct ( a[row][*] -- xt )

\ xt is of type ( b[*][column] -- n )

>r :noname r>

0 ]] literal SWAP

[[ row-size 0 do ~~ ]]

dup @

[[ dup @ ]] literal * under+ cell+

[[ row-byte-size + loop

drop ]] drop ;

[[ ;

a gen-innerproduct b swap execute .

This code uses the syntax ]] x y [[, which is
equivalent to postpone x postpone y, but more
readable. The staged code uses the same stack
depth reduction techniques (except the return
stack, which becomes unnecessary) as the origi-
nal code, but it adds staged execution; this results
in less stack shuffling, and no need to use the re-
turn stack (except to get the parameter a past the
:noname. The second stage then contains an un-
rolled loop that contains the values from the vector
a; in source code it would look like this (for a three-
element vector a containing 5, -3, 2):

:noname

0 swap

dup @ 5 * under+ cell+

dup @ -3 * under+ cell+

dup @ 2 * under+ cell+

drop ;

Of course, this technique incurs the CPU and
memory costs of generating the code for the sec-
ond stage, and is normally only efficient if the sec-
ond stage is used several times (if it is used often
enough, it can be significantly more efficient than
the single-stage code [LL96], if the Forth compiler
supports fast code generation); and the program-
mer may have to deal with recovering the memory
for the generated code.

So, this technique is not very general-purpose,
but it still is an interesting addition to the arsenal
of stack depth reduction techniques.

11 Pipelines

An program can be organized as multiple tasks that
are connected in a pipeline. One reason for this or-
ganization is that it allows the flexible composition
of useful reusable parts; that is the main reason for
using pipelines in Unix. Another benefit of pipelines
is that the tasks of a pipeline (pipeline stages) can
be executed in parallel.

In the context of our topic the benefit is that
each task has its own stack; if we have multiple pa-
rameters to pass in and multiple data to handle,
hopefully each task needs only a part of these pa-
rameters and only needs to deal with a part of the
data, reducing the stack depth pressure in that task,
compared to a program that tries to do it all in a
single task.

I am not aware of an implementation of this idea,
but it should not be hard to implement on a multi-
tasking Forth system. In any case, the following is
just a somewhat elaborate idea, not something you
can use as programmer at the moment.

The following code fetches a vector x from mem-
ory, multiplies it with an FP number a, and adds the
product vector to another vector y in memory. This
is a common linear algebra function (called SAXPY,
DAXPY, etc. in BLAS, depending on the type). In
our pipelined implementation each of these steps
(fetching, multiplying, adding) has its own pipeline
stage:

: v@ ( f-addr nstride ucount -- )

0 ?do

over f@ fput

tuck + loop

endput 2drop ;

: vf* ( ra -- )

begin fget? while

fover f* fput repeat

fdrop ;
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: v+! ( f-addr nstride -- )

begin fget? while

over f@ f+ over f!

tuck + repeat

2drop ;

: faxpy ( ra f-addr-x nstride-x

f-addr-y nstride-y ucount -- )

rot rot 2>r [’] v@ xxx|

[’] vf* f|

2r> v+! ;

Here the input parameters are the start address
address, stride2, and size of x, the value of a, and
the address and stride of y (the size is the same as
for x). So we have five cell-sized parameters and one
FP parameter, too many for handling in one func-
tion with stack manipulation words only (therefore
I present no version without pipelining).

In our pipelined version each pipeline stage only
has to handle a few of the parameters, and conse-
quently there is little stack manipulation code. The
interface word faxpy sees them all, but only has to
pass them to the stages, which is relatively simple.

Each pipeline stage passes its FP result with fput

to the next stage, which receives it with fget?.
The connections between the stages are implicit,

so we can only have a linear pipeline. Linear
pipelines have been good enough for a lot of work
in Unix, but one still might want to consider less re-
stricted options (ideally, any data-flow DAG); the
main disadvantage would be that we then have to
identify which connection an fput or fget? refers
to, and since this identifier would be passed on the
data stack, this would increase the stack load. An-
other disadvantage of data-flow graphs beyond trees
is that simple pipeline implementations can lead to
deadlocks.

12 Conclusion

In this paper we look at various ways to reduce the
stack load. There is no silver bullet, except locals.
Yet, using a combination of the other techniques,
most of the time it is possible to keep the stack
load manageable even if we do not use locals: us-
ing the return stack, the counted loop parameters
and various implicit parameters present in the Forth
system.

The Postscript graphics model shows how a prob-
lem that appears hard for stack-based languages can
be solved using such techniques.

We also present the more exotic (in Forth) tech-
niques of staged execution and pipelines, which pro-

2The stride parameter allows using the function on vec-

tors that are not consecutive in memory, e.g., a column or

diagonal of a matrix.

vide additional weapons against high stack item
pressure.
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